ShiVa Developer Forum • View topic - Windows 10 Shiva 1.9.2.0 and AT 1.4 problem
 

Windows 10 Shiva 1.9.2.0 and AT 1.4 problem

Tools for ShiVa...

Windows 10 Shiva 1.9.2.0 and AT 1.4 problem

Postby Psychopsam » 2018-08-23 18:13

Hi,

I'm trying to export my game to build to Windows.

I export it as an STK using the default settings.

If I right click on the STK and open with the S3DEngine it works fine

If I try to use the AT 1.4 on it, it fails to build with the error ....

-----------------------------------------------------------------------------
-- New build for Windows (tool version: 1.4.0)
-----------------------------------------------------------------------------
Validating application content
Deleted directory: D:/_S3DTempBuild_/StarTrekTCS_Win_001_Windows.s3dxproj
Created directory: D:/_S3DTempBuild_/StarTrekTCS_Win_001_Windows.s3dxproj
Created directory: ./
Copied file: D:/Shiva192/ShiVa Technologies/ShiVa Authoring Tool/Data/Windows/Windows/Build/S3DEngine_Windows.exe to: D:/_S3DTempBuild_/StarTrekTCS_Win_001_Windows.s3dxproj/S3DEngine_Windows.exe
Could not add STK file D:\ShivaProjects\StarTrekTCS\Release\PC\StarTrekTCS_Win_001.stk

Any idea why the build is failing?

Andy H.
Psychopsam
Platinum Boarder
Platinum Boarder
 
Posts: 446
Joined: 2009-03-26 00:48

Re: Windows 10 Shiva 1.9.2.0 and AT 1.4 problem

Postby broozar » 2018-08-23 20:51

apart from 192/14 being very out of date?
Make sure the folders are writable, the files can be copied, and are not used/locked by another process (like the player).

Try a reboot, try a different folder/drive.

If everything fails: 1.4 Windows does not actually build anything, it just copies files around and writes a config file. I can give you a list of what to copy, let me know if the other ideas don't help.
User avatar
broozar
Administrator
Administrator
 
Posts: 4148
Joined: 2007-09-16 10:22
Location: Berlin - Germany

Re: Windows 10 Shiva 1.9.2.0 and AT 1.4 problem

Postby Psychopsam » 2018-08-24 18:01

Okay so should I be using version 2 now or are there newer versions of 1.9.x and the AT? (where can I get the latest versions of those?)
I just wasn't sure how feature complete and releasable version 2 was at this point so I stuck with my originals.
Psychopsam
Platinum Boarder
Platinum Boarder
 
Posts: 446
Joined: 2009-03-26 00:48

Re: Windows 10 Shiva 1.9.2.0 and AT 1.4 problem

Postby broozar » 2018-08-24 18:17

for export, you should definitely use 2.0 - especially since it loads 1.9.2 projects without modification. the new engine builds, targets and fixes make it worth it, not to mention that some platforms like iOS or Android are no longer supported by UAT 1.4.

For game creation, you can continue to use 1.9.2 if you want or need to because of some missing feature. There are no newer versions of 1.9.2 or 1.4, and the products have been on the legacy list for a while, meaning they get no more support, fixes or updates.
User avatar
broozar
Administrator
Administrator
 
Posts: 4148
Joined: 2007-09-16 10:22
Location: Berlin - Germany

Re: Windows 10 Shiva 1.9.2.0 and AT 1.4 problem

Postby Psychopsam » 2018-08-25 02:10

Awesome thanks :D
Psychopsam
Platinum Boarder
Platinum Boarder
 
Posts: 446
Joined: 2009-03-26 00:48


Return to External tools

Who is online

Users browsing this forum: No registered users and 2 guests

cron