ShiVa Developer Forum • View topic - need help. build apk problems
 

need help. build apk problems

Google Play Store, Amazon Kindle, Nook, and so many more

need help. build apk problems

Postby 25kb » 2018-02-10 02:27

hey guys i have a problem. first ill say that i have followed the android authoring instructions. i have set android home, java home, jre,jdk latest, ant etc. to their right paths(ant in c:/ant for example).. i downloaded the latest ndk and sdk separately not in android studio. i tried typing in cygwin terminal make -v and the make file was the latest.. but i still got this error.

bash cannot set terminal process group(-1): inappropriate ioctl for device

bash no job control on this shell

bash/cygdrive/D/NDK/ndk-build no such file or directory

cannot build jni module

i have changed the location of ndk multiple times, simplifed the folder names still git this error.. the no file or directory in particular.


i think its the cygwin bash but i downloaded the make file only at first then downloaded again with all the devel packages. still the same error .. by the way does the latest 1.9.2 and latest authoring tool can still build games with latest ndk/sdk/ant ? is there something im missing? minimum os target is android 4 kitkat and yes i downloaded installed/extracted at the right path double checked. still no error..

i wonder if its because my user name in pc has spaces in it? is that the reason it cannot see my ndk file/folder? i read here somewhere android does not like spaces much.

iam using windows 10 32 bit enterprise.

i tried opening in eclipse doing some experimental stuff adjustments 8-) still the apk installed is empty

btw if this has been asked before and got solved kindly point me to the thread although im not sure if it is still applicable since some of them are years old.. thanks guys.
25kb
Fresh Boarder
Fresh Boarder
 
Posts: 7
Joined: 2017-11-28 08:58

Re: need help. build apk problems

Postby 25kb » 2018-02-10 12:35

its the sdk and ndk. or just the ndk .most likely just the ndk i think i need to use the 2013-14 version or something. lots of incorrect paths and commands that i have to fix manually .. if there is an ndk version that works for you guys on uat 1.4.0 then i would really apreciate it if you tell me..
25kb
Fresh Boarder
Fresh Boarder
 
Posts: 7
Joined: 2017-11-28 08:58

Re: need help. build apk problems

Postby broozar » 2018-02-10 14:48

hi 25kb,

the engines and guides for UAT 1.4.0 as well as SDKs/NDKs for Android from that era are so very out of date that neither We nor Google officially support it any longer. To publish to Android these days, you need to have ShiVa 2.0 beta 9, Android Studio 3, and install its dependencies (SDK/NDK/CMake) from there. cygwin, ANT and Java are still separate installations. Please follow the current, official documentation: http://www.shiva-engine.com/doc/publishing/android/

You can still target old devices running Android 2.3.3 or 4.0, but you have to do it through the modern toolchain. I don't know if anyone besides you has tried to run the 1.4 UAT with the modern AS toolchain, but even if it worked, your app would have security flaws caused by a now-outdated SSL lib which has been patched for ages in 2.0, which would lead to Google rejecting your software. So even if you got it to work, it would still be not the proper solution. There is no way around Android Studio 3 and ShiVa 2.0.
User avatar
broozar
Administrator
Administrator
 
Posts: 4158
Joined: 2007-09-16 10:22
Location: Berlin - Germany

Re: need help. build apk problems

Postby 25kb » 2018-02-11 00:40

thanks broozar. yeah i know i just want to test something on my android. im not really trying to publish on it it or something..its all good now.
25kb
Fresh Boarder
Fresh Boarder
 
Posts: 7
Joined: 2017-11-28 08:58


Return to Google Android

Who is online

Users browsing this forum: No registered users and 4 guests

cron