ShiVa Developer Forum • View topic - UAT -> Could not find debug token AuthorID
 

UAT -> Could not find debug token AuthorID

BlackBerry Tablet OS and BlackBerry 10

UAT -> Could not find debug token AuthorID

Postby Alex88 » 2014-03-29 09:43

Hello together,

I try to export my game to BlackBerry OS 10 but in the UAT I always get the following error:

-----------------------------------------------------------------------------
-- New build for BlackBerry (tool version: 1.4.0)
-----------------------------------------------------------------------------
Using output folder: C:\Users\Alex\Projekte\Shiva3D\Publish\BlackBerry
Using temporary folder: C:/Users/Alex/AppData/Local/Temp/_S3DTempBuild_/MrDonerKebab_0.7b_BlackBerry.s3dxproj
Using NDK version: 10
Validating application content
Using Icon: C:/Users/Alex/Projekte/Mr Doner Kebap/Icons/fertig/Logo5.png
Using Splash: C:/Program Files (x86)/ShiVa Technologies/ShiVa Authoring Tool/Data/Windows/BlackBerry/Build/S3DSplash_1024x600.png
Validating tools path
Using BlackBerry NDK: C:\Entwicklung\bbndk
Using QNX target directory: C:/Entwicklung/bbndk/target_10_2_0_1155
Using QNX host directory: C:/Entwicklung/bbndk/host_10_2_0_15
Using Cygwin : C:\Entwicklung\cygwin
C:\Entwicklung\cygwin/bin/bash.exe --login -i -c cd "C:/Entwicklung/bbndk/host_10_2_0_15/win32/x86/usr/bin" && ./blackberry-nativepackager.bat -listmanifest "C:/Users/Alex/AppData/Local/Research In Motion/debugtoken1.bar"
Could not find debug token AuthorID for identity aLotEntertainment


I tried the command

C:\Entwicklung\cygwin/bin/bash.exe --login -i -c cd "C:/Entwicklung/bbndk/host_10_2_0_15/win32/x86/usr/bin" && ./blackberry-nativepackager.bat -listmanifest "C:/Users/Alex/AppData/Local/Research In Motion/debugtoken1.bar"


in the cmd but the ./blackberry-nativepackager.bat is the problem. Unknown command. When I write the command together "C:/Entwicklung/bbndk/host_10_2_0_15/win32/x86/usr/bin/blackberry-nativepackager.bat" it works. :?:

I use Windows 7 Ultimate 64 Bit, UAT 1.4.0 and Momentics IDE for BlackBerry
Version: 2.0 Build id: v201310251603.
Alex88
Junior Boarder
Junior Boarder
 
Posts: 31
Joined: 2014-02-14 08:25
Location: Germany

Re: UAT -> Could not find debug token AuthorID

Postby .eb » 2014-03-30 00:25

starting at the beginning to make this faster to solve.

1. did you set your device into development mode ? (not the problem here but asking just for the sake of it, as you need to create debug tokens and upload to device)
2. did you open eclipse/YourChosenIDE and setup your device; AKA: create a debug token and upload it to your device ? This step requires you to create passwords.
I think Momentics has this function set in the same spot as Eclipse.


Could not find debug token AuthorID for identity aLotEntertainment





--------------------------------------------------
There is at least 1 walk through for Blackberries. Check the Docs & Wiki Plz.
I made some helpful .bat files for BBndkVersion2, so adjust them for verison10 and use them to ease your pain..

BB201Signer.bat
Code: Select all
cd C:\SDKs\BBNDK10\Path-To-Signer\
blackberry-signer -storepass **YOURPASSWORDHERE** %1
pause

Univeral_jarsign_Check.bat
Code: Select all
C:\SDKs\jdk1.6.0\bin\jarsigner.exe -verify -verbose -certs %1
pause


I drag and drop my files onto these .bat files to sign/check/etc.
.eb
Platinum Boarder
Platinum Boarder
 
Posts: 378
Joined: 2010-11-10 16:47
Location: Syracuse NY

Re: UAT -> Could not find debug token AuthorID

Postby Alex88 » 2014-03-30 09:12

Hi .eb,

yes my device is in the develop mode and I have successful create a debug token and upload it to the device.

I also tried to write the company name lowercase and in the develop mode the debug token is correct, but I still get the same error.

I tried to change the build type to "Distribution" but in the build process I get an error "unknown command >java<". But of course I have installed java because I can successfully export to android. :cry:
Alex88
Junior Boarder
Junior Boarder
 
Posts: 31
Joined: 2014-02-14 08:25
Location: Germany

Re: UAT -> Could not find debug token AuthorID

Postby .eb » 2014-03-30 10:06

make a new debug token and send it to the device as well. try again.
iirc, I had to do do this too to get the first build completed too.

If that doesnt help then I'd ask if you have Java 1.6 installed and NOT 1.7 or newer(I remember having issues with 7/1.7.. but this could have changed.


Other than that, I am not sure what to say. Someone else should be along to help you on Monday'ish.
.eb
Platinum Boarder
Platinum Boarder
 
Posts: 378
Joined: 2010-11-10 16:47
Location: Syracuse NY

Re: UAT -> Could not find debug token AuthorID

Postby Alex88 » 2014-03-31 08:13

Yes, you are right, I have installed the latest Java version. I will try your tip. :wink:
Alex88
Junior Boarder
Junior Boarder
 
Posts: 31
Joined: 2014-02-14 08:25
Location: Germany

Re: UAT -> Could not find debug token AuthorID

Postby .eb » 2014-04-01 03:37

I'll check back on this thread, so give a reply. If we need to, I'll have you send me your file(s) and I'll process them to see if I can get it on the Dev Alpha C 10 device.
.eb
Platinum Boarder
Platinum Boarder
 
Posts: 378
Joined: 2010-11-10 16:47
Location: Syracuse NY

Re: UAT -> Could not find debug token AuthorID

Postby Alex88 » 2014-04-12 17:05

Thank you for your offer! :) I will write you a pm when I don't get it work.
Alex88
Junior Boarder
Junior Boarder
 
Posts: 31
Joined: 2014-02-14 08:25
Location: Germany


Return to BlackBerry

Who is online

Users browsing this forum: No registered users and 0 guests

cron